]> Dogcows Code - chaz/yoink/blobdiff - build/arch/gentoo/yoink.ebuild
build system enhancements
[chaz/yoink] / build / arch / gentoo / yoink.ebuild
similarity index 62%
rename from arch/gentoo/yoink.ebuild
rename to build/arch/gentoo/yoink.ebuild
index 6e167d0bf3daa0424232b349e463145f3e0104e8..b27524e9e5a489a9409349ce7da70430863cda77 100644 (file)
@@ -2,18 +2,16 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-EAPI=2
-
+EAPI=3
 inherit eutils games
 
 DESCRIPTION="Alien-smashing action game"
-HOMEPAGE="http://www.dogcows.com/yoink/"
-SRC_URI="http://www.dogcows.com/yoink/chrome/site/${P}.tar.bz2
-       http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
+HOMEPAGE="http://www.dogcows.com/yoink"
+SRC_URI="ftp://ftp.dogcows.com/yoink/${P}.tar.bz2"
 
 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~ppc x86"
 IUSE="debug double-precision gtk hotload qt4 threads"
 
 RDEPEND="dev-lang/lua
@@ -30,8 +28,9 @@ DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
 src_configure() {
-       egamesconf \
-               --disable-dependency-tracking \
+       egamesconf --disable-dependency-tracking \
+               --install-icon=no \
+               --print-instructions=no \
                $(use_enable debug) \
                $(use_enable double-precision) \
                $(use_enable hotload) \
@@ -41,10 +40,9 @@ src_configure() {
 }
 
 src_install() {
-       emake DESTDIR="${D}" install_man=no install || die "emake failed"
-       dodoc AUTHORS COPYING README TODO
-       doman doc/yoink.6
-       doicon data/yoink.png
-       make_desktop_entry ${PN} Yoink
+       emake DESTDIR="${D}" install || die "Install failed"
+       dodoc AUTHORS COPYING README TODO || die "Install docs failed"
+       doicon data/yoink.png || die "Install icon failed"
+       make_desktop_entry yoink Yoink || die "Install destop entry failed"
        prepgamesdirs
 }
This page took 0.02102 seconds and 4 git commands to generate.